Symptoms

A trigger (such as an Email Trigger or File Trigger) uses a selection script to filter events before triggering. If the selection script references a Script Library and that library is modified, the trigger script fails to evaluate, causing the trigger to be suspended.

More Information

When this problem occurs, adTempus logs alert 5103:

The selection script for trigger "[trigger description" failed. See additional messages below for more information. This trigger will be disabled until the job is edited and saved.   

adTempus also logs alert 5070:

Script execution failed because the script threw an exception: Could not load file or assembly 'ScriptLibrary.[guid].[timestamp], Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

Cause

This occurs because the trigger is using a cached copy of the selection script and the libraries it references. As a result the script engine attempts to use the wrong version of the library from its cache, and this fails because that version no longer exists.

Workaround

After modifying a Script Library that is referenced by a trigger selection script, you must reload the trigger. There are two ways to do this:

  • Edit the affected job(s) and click OK without modifying anything.
  • Restart the adTempus service

Resolution

This problem was corrected so that the trigger no longer tries to use the out-of-date script libraries.

Status

  • adTempus 4
    This issue will not be fixed in this version of the software.

  • adTempus 5
    This issue has been corrected and the fix will be included in the next maintenance update or software release. Customers affected by the problem may contact us to obtain the fix now.