Symptoms

A job triggered by a Job Trigger will be run on the Controller instead of on the Agent(s) the job is configured to use, if the trigger has the Only match jobs running on the same computer option selected

Cause

adTempus 5.0 included a change (CR7550) that changed the behavior of the Job Trigger so that if the Only match jobs running on the same computer option is checked, the triggered job runs on the same computer as the triggering job. Due to a problem with the way this change was implemented, this option causes the triggered job to be run on the Controller rather than on the Agent where the triggering instance ran. 

Workaround

To avoid this problem, uncheck the Only match jobs running on the same computer option on the Job Trigger.

Status

  • adTempus 5
    This issue has been corrected and the fix will be included in the next maintenance update or software release. Customers affected by the problem may contact us to obtain the fix now.