Symptoms
After upgrading an adTempus instance from version 4.x to version 5, some Job Control Actions may fail to execute (the target job is not run).
More Information
The Alerts view of the Console will contain the following error (message code 104):
The adTempus server diagnostic log will contain lines similar to the following:
In this scenario, editing the job and saving it without making any changes causes the action to work correctly on the next run.
Cause
This problem occurs if the adTempus 4.x data contains an obsolete option value (generally left over from a prior upgrade from adTempus 3.x). adTempus 5 fails to ignore this invalid value, resulting in the error.
Resolution
To resolve this problem, apply the update listed below.
The problem can also be resolved by executing the following update against the adTempus database (instructions):
update jobcontrolaction set executionoptions=executionOptions & (~264)
Status
adTempus 5
This issue has been resolved. Resolved in version 5.0.3.