Symptoms

When you try to duplicate certain items (such as a Step or Response within a job), the Console connection to the server fails. This happens only when using an adTempus 5.x Console to connect to a 4.x server.

More Information

When you duplicate the item, the duplicate is successfully created and displayed for editing. When you click OK to save the new item, the "Please Wait..." window displays indefinitely. If you swap to the main Console window (using Alt-Tab or selecting it from the Task Bar) you will see message "The server connection has failed or been closed." Once you acknowledge this message, you can switch back to the previous window and will see a separate message similar to the following:

ADT005166E: The server connection has failed or has been closed: The formatter threw an exception while trying to deserialize the message: There was an error while trying to deserialize parameter http://arcanadev.com/adTempus/4.0:objectsToValidate. The InnerException message was 'There was an error deserializing the object of type ArcanaDevelopment.adTempus.EntityCore.DTOCollection`1[[ArcanaDevelopment.adTempus.EntityCore.DTOBase, ArcanaDevelopment.adTempus.EntityCore, Version=4.0.0.0, Culture=neutral, PublicKeyToken=775b02d94c648425]]. The value 'Fail' cannot be parsed as the type 'Int32'.'.  Please see InnerException for more details.

Cause

This occurs due to a backward-compatibility in the adTempus 5.x Console.

Resolution

Update the Console to a version containing the fix. The server does not need to be updated.

Status

  • adTempus 5
    This issue has been resolved. Resolved in version 5.0.3.