Symptoms
The adTempus service fails to start. Windows provides a generic error message:
The adTempus service on Local Computer started and then stopped. Some services stop automatically if they have no work to do, for example, the Performance Logs and Alerts service.
In the Application log of the Event Viewer, adTempus reports the following error messages:
Server initialization failed. Check previous Event Log messages for additional information, or contact support personnel.
Failed to initialize listeners for remote connections: There is already a listener on IP endpoint 0.0.0.0:3760.
Cause
This problem can happen in some cases when the adTempus service is restarted (either manually or automatically after a service crash) while jobs are running. When steps are running with the "Capture Console Output" option, those processes have "inherited" the handles to the IP ports that adTempus uses for communication between components, and therefore those handles are not closed when adTempus shuts down. As a result, when it restarts and tries to open those ports, it fails because they are already in use by other processes.
Resolution
Generally it is possible to start the service after waiting for the processes that were running at the time of the service restart to finish, or after terminating those processes through Task Manager. If the adTempus script host process (adtempus.jobhost.exe or adtempus.jobhost32.exe) is running, you may need to terminate it as well.
If that is not effective, it will be necessary to restart the computer.
To prevent the problem from recurring in the future, you can enable port sharing for adTempus. There is no downside to enabling this capability. To do so:
- Enable and start the "Net.Tcp Port Sharing Service" as discussed in the "Requirements for Multiple Instances" section of this help topic.
- Run the Registry Editor and go to "HKEY_LOCAL_MACHINE\SOFTWARE\Arcana Development\adTempus\GlobalOptions" (you may need to create the "GlobalOptions" key).
- Add a new DWORD value named "ServiceHost:EnablePortSharing" and set it to "1".
Note that enabling port sharing will only take effect the next time the service is successfully started. If you are unable to start the service currently, enabling port sharing will not resolve your immediate problem, and you will still need to terminate running processes or restart the computer.
Other Causes
This problem can also occur if you have configured multiple instances of the adTempus server on the computer but the Net.Tcp Port Sharing Service is not running. See this help topic for more information on running multiple instances of adTempus.
Status
adTempus 4
adTempus 5