Symptoms
You add a Remote Agent to an adTempus Master but the status for the Agent shows that the connection failed because "This Agent already belongs to a different Master."
Cause
This happens because the Agent is (or was) under control of another Master.
An Agent can only be assigned to a single Master.
Resolution
To move an Agent to a new Master, first go to the Remote Agents view in the adTempus Console on the old Master and remove the Remote Agent definition (you will first need to remove the Agent from any Queues that use it). When you do this, the Master will send a signal to the Agent releasing it from control.
If you do not have access to the old Master or the Agent still reports this error after it has been released, follow these steps to reset its identity:
- Run the Registry Editor and go to key "HKEY_LOCAL_MACHINE\SOFTWARE\Arcana Development\adTempus\Instances\Default\Options". If there is an option named "MasterID", delete it.
- Run the adTempus Engine Mode utility (adtenginemode.exe). Check the box to "Reset Master" and then click OK. Allow the utility to restart the adTempus service. (See the workaround in CR00007184 if the Reset Master option is not enabled.)
The Master should now be able to connect to the Agent.
Additional References
See Resetting an Agent's Master in the online help