Symptoms

When you install adTempus 4.3, the Database Configuration Wizard runs after the software has been installed. The wizard fails with the following error message:

Error: Unrecognized parameter: "installer"

Cause

This is caused by a problem with the version of the Database Configuration Wizard included in the initial adTempus 4.3 release.

Workaround

Use one of the following workarounds depending on your situation:

If you are upgrading from adTempus 4.0, 4.1, or 4.2

You can ignore this problem, as the Database Configuration Wizard does not need to run. Click Close to close the Database Configuration Wizard and return to the main setup wizard. Once that finishes, you will need to start the adTempus service manually.

If you are installing a new instance of adTempus, or upgrading from adTempus 3.x

1. When the error occurs, click Close to close the Database Configuration Wizard.

2. You will be returned to the main setup wizard, which will ask you whether to remove the setup files. Make sure the box is not checked (leave the setup files in place) and note the location of the setup files ("C:\adTempus 4 Setup" by default).

3. Click Next to close the main setup wizard.

4. Run the adTempus Database Configuration Wizard from the Start menu (or by running "adtdbconfig.exe" in the adTempus program folder).

5. On the Welcome page, click Next.

6. The Wizard will display a message telling you that SQL Server is required. If you plan to use a standalone SQL Server instance, no additional action is necessary. Click Next to continue with the Wizard.

7. Otherwise, click Browse and browse to the folder where the adTempus setup files are located (noted in step 2). Select the SQL Server Express installer, which will start with "SQLEXPR" (e.g., "SQLEXPR_x64_ENU_2012sp1").

8. Click Next and continue with the wizard.

Note: If you have already canceled installation and deleted the setup files: The adTempus software is still installed. You can rerun the setup package to extract the files (you need the SQL Server Express installer that is included in the package), then cancel the software installation and proceed from step 4.

If you have canceled and uninstalled, you can download and run the updated installation package instead of rerunning the original.

Resolution

New versions of the adTempus 4.3 setup packages were released on April 7, 2016, to correct this problem.

Status

  • adTempus 4
    This issue has been resolved. Resolved in version 4.3.