Symptoms
After installing Report Commander, exports fail with an error similar to the following:
Cause
This problem occurs if the Crystal Reports runtime software used by Report Commander has been corrupted or failed to install properly.
Resolution
From the Windows Control Panel, go to "Programs and Features" and locate the "SAP Crystal Reports runtime engine for .NET Framework." Note whether you have the 32-bit version or 64-bit version. Note the version number that is installed.
Uninstall the "SAP Crystal Reports runtime engine for .NET." You do not need to uninstall Report Commander.
Next locate the installer for the Crystal Reports runtime components:
- If the version number that was installed is higher than 13.0.13.1597, it was installed by a program other than Report Commander that also uses the Crystal Reports runtime. Locate the correct version on the SAP download page. Download either the "32bit.msi" or "64bit.msi" file depending on whether you have 32-bit or 64-bit version installed.
- If the version number is 13.0.13.1597 or lower, use the installer provided for Report Commander.
- If you still have the Report Commander setup files extracted on your computer, you can find the Crystal Reports runtime installer in one of the following locations:
- For 32-bit versions of Report Commander: C:\Report Commander Setup\ISSetupPrerequisites\{56A627AE-33AA-42AD-AF5F-8B6D6F9C0AAF}
- For 64-bit versions of Report Commander: C:\Report Commander Setup\ISSetupPrerequisites\{74D4DD54-629F-4758-A055-E8B07B57B0E3}
- If you no longer have the setup files extracted, you can download the 32-bit or 64-bit installer for the Crystal Reports Runtime.
- If you still have the Report Commander setup files extracted on your computer, you can find the Crystal Reports runtime installer in one of the following locations:
Run the installer to install the Crystal Reports runtime. (If you downloaded the installer, you must extract the setup program from the ZIP that you downloaded.)
After installation of the Crystal Reports runtime finishes, rerun your Report Commander export and confirm that it works properly.