Symptoms
The adTempus service fails to start an reports a database problem in the Application log in the Event Viewer. The adTempus service diagnostic log contains the following warning message:
Cause
This problem occurs because the machine configuration file for the Microsoft .NET Framework has been corrupted by another application.
Resolution
This problem can be resolved by correcting the invalid configuration file.
1. Use a text editor (such as Notepad) or an XML editor to open the file "C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config\Machine.Config". In this file, look for a line that reads as follows:
<DbProviderFactories/>
2. Delete this line and save the file.
3. Repeat steps 1 and 2 for the file "C:\WINDOWS\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config".
The adTempus service should now start correctly.
Additional Information
The adTempus Console may also fail to start due to a file permission problem, as discussed in article K00000491.