Symptoms

Your job is configured to run using a non-interactive logon session, and a program run by the job never finishes running.

Cause

This problem may happen if you use the Hidden interaction setting, and your program displays a dialog box or other window, or prompts for input from the console. Because the program is running in a hidden session, there is no way for you to see or respond to the message.

Resolution

Temporarily run the job interactively so you can see any messages being displayed by your program.

To do this:

1. Log in to the adTempus computer under the same account that is being used to run the job.

2. Check the settings for the Job Step that is hanging, and turn off capture console if it is being used:

3. Use one of these methods to run the job:

  • Run the job manually and in the Execute Job window, choose the Make the job visible on my desktop option. This will run the job in your logon session, making it visible to you.
  • Change the User Interaction setting for the job to "Interactive Required" (adTempus 4 and later) or "User's Session" (adTempus 3) and then run the job manually or on its regular schedule.

Related Issues

Some programs may hang when you use the "Capture Console" option to run the job. See:

  • K00000239: Some programs do not work properly if run in "Capture Console" mode
  • K00000485: PowerShell hangs when run in "Capture Console" mode