Symptoms

When you try to export a report that connects to a Microsoft Access database or Microsoft Excel workbook, the export fails with the following error:

Export failed: Database logon failed.: Database logon failed.

If you try to preview the report in the Project Editor or Command Line Builder, the report viewer will display a login prompt with the default "Admin" user ID. If you click OK, you get a "Logon Failed" message.

This problem happens even though the Access database is not password protected. If the database is password protected, the error happens even if you provide the correct user ID and password. 

Possible Causes

This problem may occur due to several different causes, as discussed in the following sections.

64-bit/32-bit Mismatch

This problem will occur if you are using the 64-bit version of Report Commander and your report uses the Microsoft Jet OLEDB driver to connect to the database. It happens because there is no 64-bit version of the Microsoft Jet OLEDB driver.

For most users the simplest solution is to uninstall the 64-bit version of Report Commander and install the 32-bit version instead.

Alternatively you can install the 64-bit version of the Microsoft Access Database Engine and modify your report to use that driver instead of the Jet driver. However, you cannot install both the 64-bit and 32-bit versions of the database engine on the same computer.

Conversely the problem will also occur if you have the 32-bit version of Report Commander but the 64-bit version of office. In this case you need to uninstall the 32-bit version of Report Commander and install the 64-bit version instead.

Database file not found

This problem will occur if the database file is not in the same location as when the report was edited in the Crystal Reports designer. For example, you created the report on one computer, where the database file was located at "c:\databases\sales.mdb" but you have deployed it to a different computer, and the database is now at "\\server1\databases\sales.mdb".

To resolve this problem you must override the database connection in Report Commander to point to the correct location for the database file. In the Data Source Properties window, the Server box will contain the path/name of the Access database file. If the location is not correct, check the Connect to a different database box and specify the correct path/name.