Symptoms

adTempus logs an error message similar to the following in the Application log in the Windows Event Viewer:

BackupDiskFile::CreateMedia: Backup device 'C:\Program Files\Arcana Development\adTempus\instances\default\data\database\backup\adtempus_SERVERNAME.201501010030.bak' failed to create. Operating system error 5(Access is denied.).

Cause

This error occurs if the SQL Server service account does not have permission to write to the backup folder.

Resolution

First identify the account that the SQL Server service (not the adTempus service) is running under. Typically the account will be "NT Service\MSSQL$ADTEMPUS". To confirm this, locate the "SQL Server (ADTEMPUS)" service in the Windows service manager and check to see what Log On account it uses.

Then, using Windows Explorer, edit the properties for the backup folder named in the error message (typically "C:\Program Files\Arcana Development\adTempus\instances\default\data\database\backup"). Grant Read and Write permissions on the folder to the SQL Server service account (e.g., "NT Service\MSSQL$ADTEMPUS").

More Information

See article K00000288 for information on configuring automatic backups.