Symptoms
When upgrading from adTempus 2.x or 3.x to adTempus 4.x, the database upgrade process fails with the following error message:
Cause
This problem occurs if there is more than one Credential Profile for the same user ID.
Additional Information
A problem in adTempus 3 made it possible to create multiple Credential Profiles for the same user ID, if the user ID was entered with different letter casing. For example, it should only be possible to have a single Credential Profile for user "johnr", but if a second profile was created as "JohnR" that was allowed.
The database conversion does not correctly handle this scenario, resulting in an error.
Resolution
An update to the database conversion tool is available.
Status
adTempus 4
This issue has been resolved. Resolved in version 4.2.