Symptoms
The adTempus service fails to start. In the Application log in the Event Viewer, adTempus reports an error with Event ID 42:
In the adTempus diagnostic log, one of the following errors is reported:
Cause
This error occurs because adTempus is configured to use a remote SQL Server instance but the Local System account that the adTempus service runs under does not have permission to connect to SQL Server.
Resolution
You must either:
1. Configure SQL Server to allow explicit authentication using a SQL Server user ID and password, then configure a login for adTempus to use.
2. Create a login in SQL Server for the adTempus machine account.
Explicit Authentication
To use explicit authentication, see Enabling SQL Server Security for information on how to reconfigure SQL Server to support this option.
Once SQL Server has been configured, create a login in SQL Server for adTempus to use. The login should be a member of the following roles for the adTempus database:
- db_datareader
- db_datawriter
- db_backupoperator
Once the login has been created, update the adTempus database configuration using the Registry Editor:
- Go to key "HKEY_LOCAL_MACHINE\Software\Arcana Development\adTempus\Instances\Default\Database".
- Create a new STRING value named "userID" and set it to the SQL Server user ID.
- Create a new STRING value named "password" and set it to the SQL Server password.
You should now be able to start the adTempus service.
Create Login for adTempus Machine Account
If you do not want to configure SQL Server to allow explicit security, you must create a login in SQL Server for the machine account of the computer where the adTempus service is installed. To do this, follow the instructions in article K00000616.
After creating the login, you should now be able to start the adTempus service.
References
Refer to the Using a Standalone SQL Server Instance topic in the adTempus installation guide for more information on supported scenarios for database connections and authentication.