Symptoms
When the adTempus Master tries to send data to an Agent, the update may fail with a database error (message ID 5313) such as this one:
Scenarios
This error occurs in either of the following scenarios:
1. For Security Logins:
- Windows user Y installed the adTempus software on the Agent and was provisioned as an adTempus Administrator.
- On the Master, an adTempus login also exists for user Y.
- The Master sends to the Agent an object for which permissions have been granted to user Y.
2. For other objects when running the Agent in "mixed" mode, where some jobs are created and managed locally:
- You connect the Agent to the Console and create (locally on the Agent) a Credential Profile, Notification Recipient, Service Provider, Shared Script, Shared Schedule, Holiday Set, or other top-level object.
- On the Master you create an object of the same kind with the same name.
- The Master tries to send the object (or a job that uses it) to the Agent.
Cause
This problem occurs because objects in adTempus are identified by an internal, unique identity value that is different from the name that you see. If you create a Login on the Master and on the Agent, they have different identity values even though their names are the same.
When the Master sends an object to the Agent, the Agent should check to see if there is an existing object with the same name, and map the object being sent from the Agent to the existing object even though the internal identity is different. However, the Agent is failing to do this correctly. Therefore it may try to save a login named "Y" even though a login named "Y" already exists. This results in an error from the database, which has constraints to prevent such duplicate values.
Resolution
A fix has been made to correctly map objects from the Master to the local object where appropriate.
Status
adTempus 4
This issue has been resolved. Resolved in version 4.1.