Symptoms
If you are using a Schedule Trigger that is configured to use a specific time zone, you will encounter the following problems:
- If the adTempus Console is running on Windows Server 2008, Windows 7, or newer, the list of time zones to select from will be empty.
- If the adTempus service is running on Windows Server 2008, Windows 7, or newer, the time zone may not be correctly observed (jobs may run at the wrong time).
Cause
The method adTempus uses to identify time zones is incompatible with changes made to the way Windows stores this information.
Workaround
If the adTempus service is running on Windows Server 2003 or Windows XP, you can run the Console on that computer or another computer running one of those operating systems and successfully edit the trigger.
Resolution
A fix has been made to correct this problem. It requires updates to both the adTempus server and any remote computers where the Console will be used to edit affected schedule triggers.
The fix is included in adTempus server build 3.0.8.3552 and Console build 3.0.8.1059.
Status
The fix is not yet included in a public release of the software. Affected users should submit a support request to obtain the update.
Note: This issue affects adTempus 3 and earlier. adTempus 4 and later are not affected.