Symptoms

When you try to create a new connection to an adTempus server from the adTempus Console, the connection fails with the following error:

The session is invalid or has timed out

Cause

This error happens when the following conditions are all met:

  1. The user is connecting to the adTempus server using Windows integrated security
  2. No login has been created in adTempus for the user.
  3. A login has been created in adTempus for an Active Directory group that the user belongs to.

Security logins tied to Active Directory groups are not supported by adTempus, but the Console does not prevent you from creating such a login. Due to a problem in the adTempus server, the error message noted above is returned when authentication is attempted using this approach.

Workaround

Create a login in adTempus for each user who needs to connect to adTempus.

More Information

Support for group-based logins is planned for an upcoming maintenance release. 

Status

  • adTempus 4
    This issue has been resolved. Resolved in version 4.0.1.