Symptoms

A job fails with the following error message:

ADT005194 An internal error occurred while running job "Job Name". Please contact support personnel and provide the diagnostic log file as described in http://www.arcanadev.com/go/adtlog

Reviewing the current adTempus service diagnostic log reveals the following error information:

ERROR ArcanaDevelopment.adTempus.Server.JobExecution.StepExecutor [JobExecutor(...)] - Exception in Execute
System.ArgumentException: An item with the same key has already been added.
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at ArcanaDevelopment.adTempus.Resources.ResourceManager.GetResourceManager(String section)
   at ArcanaDevelopment.adTempus.Resources.ResourceManager.GetStringResource(String resourceSection, String stringKey, TextCase caseOption)
   at ArcanaDevelopment.adTempus.Shared.JobStatusHelpers.GetJobStatusDescription(JobState status)
   at ArcanaDevelopment.adTempus.Server.JobExecution.StepExecutor.ReportStatus(JobState , ExecutionHistoryStepDTO )
   at ArcanaDevelopment.adTempus.Server.JobExecution.StepExecutor.Execute()

Cause

This error is due to a programming problem.

Note: This article applies only if the error log contains the details shown above. Other problems can produce the same ADT005194 "Internal error" message.

Status

  • adTempus 4
    This issue has been resolved. Resolved in version 4.0.1.