Symptoms

Report Commander returns the following error message when you try to preview a report that uses an ODBC connection in the Command Line Builder or to process the report from the command line:

Failed to open the connection.: Failed to open the connection

Cause

This error may occur if the ODBC alias (DSN) used by the report has not been configured on the computer where Report Commander is running. On 64-bit versions of Windows, it may occur if the alias has not been configured using the 32-bit ODBC manager.

Resolution

Use the Windows ODBC manager to verify that the ODBC alias used by the report is configured correctly. Make sure the alias is defined as a System DSN, or that it is defined as a User DSN for the user account under which Report Commander is running.

On 64-bit versions of Windows, Report Commander runs as a 32-bit application and therefore requires 32-bit ODBC drivers and DSNs. To configure the alias as a 32-bit DSN, you must run c:\windows\sysWOW64\odbcad32.exe to start the 32-bit ODBC Data Source Administrator, and add the DSN there.