Symptoms
When you install adTempus on a computer running Windows Vista, Windows 7, Windows Server 2008, or later, setup may display the following error message:
Error 1904.Module C:\Program Files\Common Files\Business Objects\2.7\bin\ExportModeller.dll failed to register. HRESULT -2147010895. Contact your support personnel.
If you click the Ignore button, the message is repeated for the following files as well:
- cachemanager.dll
- clientdoc.dll
- commonobjmodel.dll
- crqe.dll
- localcon.dll
- objectfactory.dll
- sacommlayer.dll
- crtslv.dll
- cubedefmodel.dll
- datadefmodel.dll
- rptcontrollers.dll
- requestmodel.dll
- rptdefmodel.dll
- saxmlserialize.dll
- undomanager.dll
Cause
This error may occur if some Microsoft software components required by the adTempus reporting feature are not present on the target computer.
Workaround
You can resolve this issue using one of the solutions listed below.
If you are installing on one of the affected operating systems and have not yet begun installation, you can avoid the problem by installing the components before you begin adTempus installation (solution 1).
1. Pre-install the required components
Click the Abort button to cancel installation. Download and install the Microsoft C++ Redistributable Package using one of the following links, then rerun the adTempus setup.
- Download Microsoft C++ Redistributable Package for x86 platforms
- Download Microsoft C++ Redistributable Package for x64 platforms
2. Allow the installation to complete, then repair
Click the Ignore button for each of the "failed to register" messages and allow setup to complete. Then rerun the setup program and choose the Repair option when prompted.
Status
This issue was corrected in adTempus 3.0.7, released on November 22, 2009. See article K00000361 for information about obtaining this update.