Symptoms

An adTempus job fails to start, and adTempus logs the following message in the Job Log:

Job cannot be executed because no interactive logon session is available for user username, and the job is configured to run only if interaction is available. To avoid this error, change the job settings to allow non-interactive execution.

Cause

This error occurs when the User Interaction setting you have selected for the job do not include the "Hidden" option. When you omit the "Hidden" option, you are telling adTempus that the job should not run if the interactive logon type (or types) you have selected are not available. For example, if you set the User Interaction to "User's Session," the job will run only if adTempus is able to attach to an existing logon session for the user under whose account the job is running.

Resolution

If you want the job to be able to run when no interactive logon session is present, select a User Interaction setting that includes the "Hidden" option as the final option (e.g., "User's Session, Console, Hidden"). This will instruct adTempus to use the Hidden mode if no interactive logon session is available.

If the User Interaction is already set to "Hidden" but you receive this error message when you run the job manually, make sure the Make the job visible on my desktop option is not checked in the Execute Job window when you run the job.

More Information

See article K00000294 for more information on the User Interaction settings for a job.