Symptoms
If a job runs and fails on the Master computer in a distributed scheduling configuration, the job will appear with a "Failed" status (and failure icon) in the adTempus Console. If the job subsequently runs and succeeds on an Agent (but does not run on the Master), the status remains "Failed," even though the instance list for the job shows that the most recent instance succeeded.
Cause
The Status column in the job list is based on the last instance that ran on the Master. Therefore, the job continues to show a Failed status until the job runs successfully on the Master.
More Information
This problem only applies if you are using distributed scheduling (jobs are running on more than one computer).
Workaround
The status will be corrected if the job is run successfully on the Master.
If the job cannot be run on the Master, you can run a database update to correct the status:
- Navigate to the adTempus program directory (generally "c:\program files\arcana development\adtempus") using Windows explorer and run the "adtdbutil.exe" program by double-clicking it.
- adtdbutil will connect to the adTempus database and display an empty input box in the top portion of the window.
- In the input box, enter the following text, replacing "job name" with the name of the job you need to update:
update jobstatus set status=-2147483647 where oid in(select status from job where name='Job Name')
- Press the F5 key to execute the command.
- Close adtdbutil.exe
- Restart the adTempus service and the adTempus Console. The job status should now appear correctly.
Status
adTempus 3
This issue has been resolved.