Symptoms
The adTempus service fails to start. In the Application log in the Event Viewer, adTempus logs the following message:
A catastrophic database error has occurred. adTempus may not function correctly until the adTempus service is restarted. Restart the service, then contact technical support and provide diagnostic log file [filename]
When you examine the log file specified in the message, you see a line with the following error message:
Database error -2147467259: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied. (source=Microsoft OLE DB Provider for SQL Server; native error=17; SQL state=08001)
A few lines above this message, you will see a line similar to the following:
Using SQL Server connection: provider=SQLOLEDB; server=127.0.0.1\adTempus;Database=adTempus_TEST1;Integrated Security=SSPI
Cause
This problem appears to be caused by a security update to Windows.
Resolution
Run the Registry Editor and locate the key
HKEY_LOCAL_MACHINE\SOFTWARE\Arcana Development\adTempus\Database
Edit the ConnectionString value and replace "127.0.0.1" with "." (a single period, without the quotes). You should now be able to start the adTempus service.
Status
Beginning with version 2.0.4, the adTempus database conversion/migration tool no longer uses "127.0.0.1" when setting the connection string, so this problem should not occur for customers who migrated to SQL Server after installing version 2.0.4 or later.