Symptoms
The adTempus service stops responding to clients, and stops running jobs. Symptoms may include:
- The adTempus Console stops responding
- If a new instance of the adTempus Console is started, it will take a long time to load, and no data will be displayed (no Jobs, Groups, Notification Recipients, etc. are listed).
- adTempus stops running jobs.
In all cases the adTempus service continues to run, and no errors are logged.
The problem occurs only when using the Microsoft Access database for adTempus.
Cause
This problem appears to be due to a database deadlocking issue, which blocks all threads within adTempus from executing, causing it to stop responding to the client and to stop running jobs.
Workaround
Because this issue only occurs when you use the default Microsoft Access database with adTempus, switching to MSDE or SQL Server will eliminate the problem.
More information on converting to MSDE or SQL Server is available here.
Arcana Development strongly advises all customers to use an MSDE or SQL Server database instead of Access irrespective of this issue, because they provide better performance and stability than Microsoft Access.
Status
adTempus 3
This issue has been resolved.